Wednesday, February 13, 2013

RIP Routing Configuration - Scenario

RIP Routing Configuration - Scenario



1. Title: RIP Routing Configuration-Scenario.

2. Description: The purpose of this Lab is to configure RIP on all the devices and test for ping and trace commands

3. Instructions:

1) Assign the IP address of all the devices as given below

Device
Interface
IP Address
Mask
R1
S0
S1
192.168.1.1
192.168.3.1
255.255.255.0
255.255.255.0
R2
S0
S1
192.168.1.2
192.168.2.1
255.255.255.0
255.255.255.0
R3
S0
S1
192.168.3.2
192.168.2.2
255.255.255.0
255.255.255.0

2) Bring all the interfaces to up
3) Configure RIP on all the Devices
4) From R1 issue a ping and trace command to R2 and R3

4. Commands to be executed:
On R1:
R1>enable
R1#configure terminal
R1(config)#interface serial 0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
 
R1(config-if)# no shutdown
R1(config-if)#exit
R1(config)#interface serial 1
R1(config-if)#ip address 192.168.3.1 255.255.255.0
 
R1(config-if)# no shutdown
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.3.0

On R2:
R2>enable
R2#configure terminal
R2(config)#interface serial 0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
 
R2(config-if)# no shutdown
R2(config-if)#exit
R2(config)#interface serial 1
R2(config-if)#ip address 192.168.2.1 255.255.255.0
 
R2(config-if)# no shutdown
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#network 192.168.1.0
R2(config-router)#network 192.168.2.0
On R3:
R3>enable
R3#configure terminal
R3(config)#interface serial 0
R3(config-if)#ip address 192.168.3.2 255.255.255.0
 
R3(config-if)# no shutdown
R3(config-if)#exit
R3(config)#interface serial 1
R3(config-if)#ip address 192.168.2.2 255.255.255.0
 
R3(config-if)# no shutdown
R3(config-if)#exit
R3(config)#router rip
R3(config-router)#network 192.168.3.0
R3(config-router)#network 192.168.2.0


On R1:
R1#ping 192.168.2.2
R1#ping 192.168.2.1
R1#trace 192.168.2.2
R1#trace 192.168.2.1

5. Network Diagram:
http://routersimulator.certexams.com/network-simulator-labs/Images-labs/routinglab_1.jpg
Note: .1 on router 1 S0 refers to 192.1168.1.1. Similarly other IP addresses to be interpreted.

To configure any router double click on it and select CLI. To configure this topology use this step by step guide.

(1841Router0) Hostname R1

To configure and enable rip routing on R1 follow these commands exactly.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#interface serial 0/0/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#bandwidth 64
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
R1(config-if)#exit
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit
R1(config)#

(2620XM-Router1) Hostname R2

To configure and enable rip routing on R2 follow these commands exactly.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface serial 0/0
R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R2(config-if)#exit
R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
R2(config-if)#exit
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config)#router rip
R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#exit
R2(config)#

(2620XM-Router2)Hostname R3

To configure and enable rip routing on R3 follow these commands exactly.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R3
R3(config)#interface fastethernet 0/0
R3(config-if)#ip address 30.0.0.2 255.0.0.0
R3(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R3(config-if)#interface serial 0/0
R3(config-if)#ip address 40.0.0.1 255.0.0.0
R3(config-if)#clock rate 64000
R3(config-if)#bandwidth 64
R3(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to down
R3(config-if)#exit
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R3(config)#router rip
R3(config-router)#network 30.0.0.0
R3(config-router)#network 40.0.0.0
R3(config-router)#exit
R3(config)#

(2811Router3) Hostname R4

To configure and enable rip routing on R4 follow these commands exactly.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 40.0.0.2 255.0.0.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
Router(config-if)#exit
Router(config)#interface fastethernet 0/0
Router(config-if)#ip address 50.0.0.1 255.0.0.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
R4(config)#router rip
R4(config-router)#network 40.0.0.0
R4(config-router)#network 50.0.0.0
R4(config-router)#exit
R4(config)#
To test rip routing do ping from pc1 to pc2 and vice versa. If you get replay then you have successfully configured rip routing but if you did not get replay double check this configuration and try to troubleshoot. I have uploaded a configured and tested topology in case you are unable to locate the problem spot then download this configuration file. And try to find out where have you committed mistake

No comments:

Post a Comment